Archive for January, 2009

Wireless on Asus EEE 1000HA on Ubuntu 8.10 part 3

January 5, 2009

sudo aptitude install linux-backports-modules-intrepid
get the ath5k module to load (sudo modprobe ath5k, add ath5k to /etc/modules to have it start automatically) and nothing else – blacklist ndiswrapper and ath_pci if necessary

it’s shaky wireless but at least it works. i think.

Mac OS X on Asus EEE 1000HA using iDeneb 10.5.5

January 1, 2009

http://www.enik.ch/2008/10/osx-leopard-1055-on-the-eee-1000h/
secondary: http://www.maceee.com/how-to-mac-os-x-1054-for-the-eee-pc-901-1000h-27.html

Follow the first guide, but here are some little inconveniences I ran into and how to deal with them:

Install from USB flash/hard drive – don’t hassle yourself more by trying to do this. get an external DVD drive or use a USB to IDE/SATA enclosure like me.
Freeze on setup/startup – BIOS Update to fix ACPI.
Unable to erase partition – don’t use logical/extended partitions (Ubuntu likes to make these by default.) Partition ahead of time (no need to format them though.)
Installer randomly closing – disable LAN/Audio in BIOS.
Loop of “Do you already own a mac?” over and over – bypass the intro by using this (create a “done” flag)
Read-only file system when booting with -s – boot from CD and it will automount filesystems with read/write permissions. cd into /Volumes/fs and do your thing.
“Login Items” missing in System Preferences/Accounts – I don’t know what to do..

No wired/wireless interfaces – I don’t know what to do =(